Can't Install Apps via Company Portal

Modified on Mon, 28 Apr at 8:08 PM

If you can't install apps from Company Portal, follow these steps.


Symptoms

  • Install button is missing or grayed out.
  • Installation fails midway.
  • Company Portal says "App not available".


Common Causes

  • Device not compliant with company polices.
  • Outdated Company Portal app.
  • Incorrect account sign-in.


Step-by-Step Fix

  1. Open Company Portal
    1. Make sure you're signed in with your work email.
  2. Check Device Compliance
    1. Go to Devices > tap your device > check for compliance errors
  3. Update Company Portal app
    1. On Windows, open "Microsoft Store" and search for "Company Portal".
    2. On iOS, open the App Store and search for "Company Portal".
    3. On Andriod, open the Play Store and search for "Company Portal".
  4. Restart your device
  5. Try installing again


If That Doesn't Work

  • Try removing your work account and re-enrolling the device
    • Settings > Accounts > Work/School Account > Remove (and re-add)
  • How to Submit a Support Ticket

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