Application Failed to Install (Company Portal)

Modified on Fri, 26 Jun at 3:19 PM

If an application fails to install, follow these steps.


Symptoms

  • Installation fails with an error
  • Apps stays stuck on "Installing" or "Downloading"
  • Install button does not complete


Common Causes

  • Device is not fully compliant or fully synced
  • Network issues
  • App deployment has not fully applied
  • Temporary Company Portal issue
  • Temporary internet connection issue


Step-by-Step Fix

Try this first

  1. Close Company Portal
  2. Restart your computer
  3. Open Company Portal again


Check your connection

  1. Make sure you are connected to the internet
  2. Try opening a website (for example, https://google.com)


Force a Sync with Company Portal

  1. Open Company Portal
  2. Click Settings
  3. Click Sync
  4. Wait for the sync to complete
  5. Try installing the app again


Check device compliance

  1. Open Company Portal
  2. Click Devices
  3. Select your device
  4. Confirm it shows as Compliant
  5. Resolve any issues shown


If your device does NOT show as Compliant or Active, follow this article: Device Not Compliant (Company Portal)


If That Doesn't Work

  • Wait 10-15 minutes and try again
  • Restart your computer and try again


Contact IT

Contact IT if:

  • The app continues to fail installation
  • Installation is stuck for an extended period
  • You see an error message you don’t recognize

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